Chercher: Et Ou Phrase  
Dans:          


Menu non membre

Pour les nouveau visiteurs

Entrez ici

Chercher le Forum



 

 Les Forums
  Programmation avancée
Repondre a ce sujet  

Sujet Répertoire Windev Mobile
Message envoyé le 03-01-2021 par madmax83 de Guadeloupe  
Bonjour,

je cherche désespérément à télécharger un fichier ZIP depuis Windev Mobile (sous Windev aucun souci) afin de mettre à jour mes données sur un GSM.
Et je n'y arrive pas.
Merci de me dire où je me plante
Voici mon code source:
PROCÉDURE Restauration()

     ToastAffiche("Restauration en cours",toastLong,cvMilieu)
     
     gnId_ftp=FTPConnecte(gsFtp_ftp,gsFtp_login,gsFtp_mdp)
     
     IF gnId_ftp<>-1 THEN
          
          fRepCrée(fRepEnCours)
          IF FTPRécupère(gnId_ftp,gsFtp_repertoire+"wallet.zip",fRepDonnées)=Vrai THEN
               Info("Restauration OK")
               zipOuvre("wallet","wallet.zip")
               zipExtraitTout("wallet")
               zipFerme("wallet")
               Info("Données extraites")
          ELSE
               Info("Restauration non effectuée")
          END

     ELSE
     
          Info("FTP mal configuré")
     END
     

Message envoyé le 03-01-2021 par Jackson de Bosnia and herzegovina  
FTPGet(gnId_ftp, gsFtp_repertoire+"/wallet.zip", "/storage/emulated/0/Download")

Not "fDirectory"

Message envoyé le 04-01-2021 par shiny de France  
bonjour
voici le code que j'utilisai pour les mises à jour de mes app wm en interne maintenant je passe par le MDM mais si ca peut aider :

SI MAJ_iWpAddon = Vrai ALORS
          
          
               Num_connexion               est un entier
               Chemin_APK                    est une chaîne
               
               
               //recuperation du numero de version
               SI Var_Globale.Nom_APK_INI <> "" ALORS
                    FTP.IgnoreErreur = ftpIgnoreCertificatExpiré + ftpIgnoreCertificatInvalide + ftpIgnoreNomCertificatInvalide + ftpIgnoreRévocation
                    Multitâche(10)
                    Num_connexion = FTPConnecte(Var_Globale.FTP_Serveur,Var_Globale.FTP_Login, Var_Globale.FTP_Password,Port_FTP,ftpModePassif,5)
                    SI Num_connexion = -1 ALORS
                         ToastAffiche("Problème de connexion au serveur FTP",toastCourt,cvBas,chCentre)
                         Etat_CNX_FTP = Faux
                         RETOUR
                    SINON
                         Etat_CNX_FTP = Vrai
                         //test si le fichier version.ini existe au niveau du serveur FTP
                         SI FTPFichierExiste(Num_connexion,Var_Globale.Nom_APK_INI) ALORS
                              //on recupere le fichier ini afin de voir quel est version est disponible sur le serveur FTP
                              SI FTPRécupère(Num_connexion,Var_Globale.Nom_APK_INI,SysRepStockageExterne(1,ssePublic) + "/Download/",ftpModeBinaire) = Vrai ALORS
                                   ToastAffiche("Vérification de la version iWpAddon",toastCourt,cvHaut,chCentre)
                                   Version_MAJ = INILit("VERSION", "NUMERO", "", SysRepStockageExterne(1,ssePublic) + "/Download/" + Var_Globale.Nom_APK_INI)
                                   
                                   SI Val(Version_MAJ) > Version_Iwpaddon ALORS
                                        //test si le fichier APK existe au niveau du serveur FTP
                                        SI FTPFichierExiste(Num_connexion,Var_Globale.Nom_APK) ALORS
                                             Libellé_InfoMAJ..Visible      = Vrai
                                             SELON Dialogue("Une mise à jour est disponible, souhaitez-vous l'installer ?")
                                                  // &Installer
                                                  CAS 1
                                                       //on cache certains elements
                                                       Combo_User..Visible               = Faux
                                                       Image_cadenas..Visible          = Faux
                                                       IMG_download..Visible          = Vrai
                                                       Multitâche(10)
                                                       //Download de l'apk sur le Terminal industriel
                                                       SI FTPRécupère(Num_connexion,Var_Globale.Nom_APK,SysRepStockageExterne(1,ssePublic) + "/Download/",ftpModeBinaire) = Vrai ALORS
                                                            Chemin_APK = SysRepStockageExterne(1,ssePublic) + "/Download/" + Var_Globale.Nom_APK
                                                            Info("Mise à jour téléchargée." + RC + "Lancer l'installation...")
                                                            SauveParamètre("MAJ","OUI")
                                                            SauveParamètre("DATE",DateVersChaîne(DateHeureSys()))
                                                            //Lancement de l'installation
                                                            LanceAppliAssociée(Chemin_APK)
                                                            Multitâche(10)
                                                            
                                                            Info("Mise à jour installée, redémarrer le programme")
                                                            FinProgramme()
                                                       FIN
                                                  // &Ne pas installer
                                                  CAS 2
                                                       Libellé_InfoMAJ..Visible      = Faux
                                             FIN
                                             
                                        FIN
                                   FIN
                              FIN
                         FIN
                    FIN     
               FIN
          

Message envoyé le 04-01-2021 par madmax83 de Guadeloupe  
PROCÉDURE Restauration()

     ToastAffiche("Restauration en cours",toastLong,cvMilieu)
     
     gnId_ftp=FTPConnecte(gsFtp_ftp,gsFtp_login,gsFtp_mdp)
     
     IF gnId_ftp<>-1 THEN
          
          fRepCrée(SysRepStockageExterne(1,ssePublic) + "/Download/wallet")
          IF FTPRécupère(gnId_ftp,gsFtp_repertoire+"wallet.zip",SysRepStockageExterne(1,ssePublic) + "/Download/wallet",ftpModeBinaire)=Vrai THEN
               Info("Restauration OK")
               zipOuvre("wallet",SysRepStockageExterne(1,ssePublic) + "/Download/wallet/wallet.zip")
               zipExtraitTout("wallet",SysRepStockageExterne(1,ssePublic) + "/Download/wallet/")
               zipFerme("wallet")
               Info("Données extraites")
          ELSE
               Info("Restauration non effectuée")
          END

     ELSE
     
          Info("FTP mal configuré")
     END
     

Merci, voici mon code, cela fonctionne
et pour les bases :

rib_ext est une Source de Données
HDéclareExterne(SysRepStockageExterne(1,ssePublic) + "/Download/wallet/rib.fic",rib_ext)

HLitPremier(rib_ext)

Message envoyé le 05-01-2021 par shiny de France  



Pour répondre à ce message vous devez être membre

Entrée membre    Enregistrer

  Post reply  



  
© 2021
 
Flag Counter