Chercher: Et Ou Phrase  
Dans:          


Menu non membre

Pour les nouveau visiteurs

Entrez ici

Chercher le Forum



 

 Les Forums
  Programmation avancée
Repondre a ce sujet  

Sujet Consommer un webservice REST, Fichier JSON
Message envoyé le 05-06-2021 par SlimTeam (Tunisie)  
j'ai essayé de développer une application qui utilise le fichier json suivant, mais j'ai rencontré un problème pour la lecture des données id, episode_num, ... de l'épisode numéro 1. Le problème est au niveau titre des épisodes (Valeur numérique).
Comment résoudre ce type de problème avec Windev Mobile?

exemple :
"episodes": {

    "1": [
        {
            "id": "3000",
            "episode_num": 1,
            "title": "The BlackList S01 Episode 01",
            "container_extension": "mp4",
            "info": {
               "movie_image": "",
               "plot": "Description",
               "releasedate": "2013-09-23",
               "rating": 6
            },
            "custom_sid": "",
            "added": "1545218787",
            "season": 1,
            "direct_source": ""
        },
"2": [..],
"3": [..],
"4": [..],
"5": [..]
}

Message envoyé le 06-06-2021 par Mbombo (Cameroun)  
STRESULT est une structure
     id est une chaîne
     episode_num est un entier
     title est une chaîne
     container_extension est une chaîne
     info est un STinfo
     custom_sid est une chaîne
     added est une chaîne
     season est un entier
     direct_source est une chaîne
FIN

STinfo est une structure
     movie_image est une chaîne
     plot est une chaîne
     releasedate est une chaîne
     rating est un entier
FIN

Resultat est un tableau de STResult

Bien vouloir envoyer le bon format JSON voilà ce que j'ai interprété.


J'apprend le WLangage tous lesjours grâce à ces Vidéos sur WinDev, WinDev Mobile et WebDev

Message envoyé le 06-06-2021 par SlimTeam (Tunisie)  
{"episodes": {

    "1": [
        {
            "id": "1000",
            "episode_num": 1,
            "title": "Film S01 Episode 01",
            "container_extension": "mp4",
            "info": {
               "movie_image": "",
               "plot": "Description",
               "releasedate": "2013-09-23",
               "rating": 6
            },
            "custom_sid": "",
            "added": "1545218787",
            "season": 1,
            "direct_source": ""
        },
        {
            "id": "2000",
            "episode_num": 1,
            "title": "Film S01 Episode 02",
            "container_extension": "mp4",
            "info": {
               "movie_image": "",
               "plot": "Description",
               "releasedate": "2013-09-24",
               "rating": 6
            },
            "custom_sid": "",
            "added": "1545218788",
            "season": 1,
            "direct_source": ""
        }
       ] ,
       "2": [
        {
            "id": "4000",
            "episode_num": 1,
            "title": "Film S02 Episode 01",
            "container_extension": "mp4",
            "info": {
               "movie_image": "",
               "plot": "Description",
               "releasedate": "2013-09-23",
               "rating": 6
            },
            "custom_sid": "",
            "added": "1545218787",
            "season": 2,
            "direct_source": ""
        },
        {
            "id": "5000",
            "episode_num": 2,
            "title": "Film S02 Episode 02",
            "container_extension": "mp4",
            "info": {
               "movie_image": "",
               "plot": "Description",
               "releasedate": "2013-09-24",
               "rating": 6
            },
            "custom_sid": "",
            "added": "1545218788",
            "season": 2,
            "direct_source": ""
        }
       ]
}
}

Le résultat :
STRESULT est une structure
    episodes est un STepisodes
FIN

STepisodes est une structure
    '1' est un tableau de ST1
    '2' est un tableau de ST2
FIN

ST1 est une structure
    id est une chaîne
    episode_num est un entier
    title est une chaîne
    container_extension est une chaîne
    info est un STinfo
    custom_sid est une chaîne
    added est une chaîne
    season est un entier
    direct_source est une chaîne
FIN
.....

La question comment manipuler des éléments de la structure "STepisodes" :
    '1' est un tableau de ST1
    '2' est un tableau de ST2
Je peux pas pas manipuler les sous branches qui ont des titres numérique.


Message envoyé le 06-06-2021 par Mbombo (Cameroun)  
Je pense que tu peux faire
POUR TOUT stElt DE episodes.1
Code de remplissage
FIN

J'apprend le WLangage tous lesjours grâce à ces Vidéos sur WinDev, WinDev Mobile et WebDev

Message envoyé le 06-06-2021 par SlimTeam (Tunisie)  
Non ça marche pas !!!
Je suis bloqué pour la sous branche "1" et "2"

Message envoyé le 07-06-2021 par cleron (France)  
Ceci devrait te donner quelques pistes https://www.youtube.com/watch?v=ABfVXpYtj_A

Message envoyé le 07-06-2021 par zorg (France)  
bonjour, je suis sur une APP windev mobile.

je travaille avec des API qui proviennent API plateform, c'est dire que le format de api playload est un standard pas un truc fait par un poissonnier ou un boulanger !!!

est bien C'EST JUSTE UN ENFER de gérer les api playload.
des conversions a gogo, pour enfin pouvoir gerer le playload. sans compter qu'il faut en plus gerer tout ca dans des thread secondaire. un truc de malade en windev mobile.

tout ça pour dire avec les produit PCMOU C'EST AU CAS PAR CAS !!! cela dépend de la version windev, de qui et comment le playload est renvoyer, quel est le format ...

....

Message envoyé le 07-06-2021 par SlimTeam (Tunisie)  
Merci à tous
Problème résolu



Pour répondre à ce message vous devez être membre

Entrée membre    Enregistrer

  Post reply  



  
Retour © 2021 forum.acam.ca
  
Flag Counter