Chercher: Et Ou Phrase  
Dans:          


Menu non membre

Pour les nouveau visiteurs

Entrez ici

Chercher le Forum



 

 Les Forums
  Programmation avancée
Repondre a ce sujet  

Sujet Problème entre 2 Fichiers de Données
Message envoyé le 10-09-2021 par Gracelmann (Congo)  
Bonjours les Acamiens !

J’ai un souci majeur qui m’a pris quasiment 2 semaines de réflexions.

Je compte permettre aux utilisateurs de faire de la suppression d’enregistrement comme bon leur semble ; une suppression qui sera conditionnée par la création d’une copie de l’enregistrement de la même information dans un autre Fichier de données conçue pour ça, ça permettra au reporting au clôture de la journée.

Le problème c’est qu’il y a une rubrique DATE dans ‘’SUPPR_Inscriptions’’ où la date du jour devrait être inscrite mais malheureusement le champ DATE_SUPPRESSION = demeure vide, toutefois que je refais l’opération il y a bien ajout d’enregistrement dans le Fichier de Données ‘’ SUPPR_Inscriptions’’ mais le champ DATE_SUPPRESSION demeure toujours vide.

Voici mon code :

Sablier(Vrai)

SI ONG_CONSULTATION.BAO_RESOLUTION.TABLE_RESULTAT_DOUBLE.COL_CODE_ID[ligneComptage] <2 ALORS
     Erreur("Aucun doublon n'a été trouvé pour la sélection actuelle !")
SINON
     SI OuiNon("Êtes-vous sûr(e) de vouloir vraiment supprimer cet enregistrement en double ?")=Vrai
          POUR TOUT Inscriptions SUR IDINSCRIPTION_FRANCS
               SI Inscriptions.IDINSCRIPTION_FRANCS = gnXIDParentApprenantASupprimer ALORS
                    
                    // Ajoute l'enregistrement dans le fichier Rapport de suppression avant la suppression
                    HCopieEnreg(SUPPR_Inscriptions, Inscriptions)
                    HAjoute(SUPPR_Inscriptions)
                    
                    //Suppression sur Doublon
                    HSupprime(Inscriptions)
                    
                    //Actualisation des Tables
                    Actualise_Doublons_Inscprition()
                    
                    
                    ToastAffiche("Suppression du doublon terminée avec succès !", toastCourt, cvMilieu, chCentre, RougeClair)
               FIN
          FIN
     FIN
     
FIN

//On met à jour la Date de suppression
POUR TOUT SUPPR_Inscriptions SUR IDINSCRIPTION_FRANCS
     SI SUPPR_Inscriptions.IDINSCRIPTION_FRANCS = gnXIDParentApprenantASupprimer ALORS
          SUPPR_Inscriptions.DATE_SUPPRESSION = DateSys()
          
          HModifie(SUPPR_Inscriptions)
     FIN     
FIN


Sablier(Faux)




J’ai même ajouté ce Code ci-dessous, pas d’actualisation :

//On met à jour la Date de suppression
POUR TOUT SUPPR_Inscriptions SUR IDINSCRIPTION_FRANCS
     SI SUPPR_Inscriptions.IDINSCRIPTION_FRANCS = gnXIDParentApprenantASupprimer ALORS
          SUPPR_Inscriptions.DATE_SUPPRESSION = DateSys()
          
          HModifie(SUPPR_Inscriptions)
     FIN     
FIN


Je continue à réfléchir, cependant si quelqu’un a une solution ce serait vraiment salutaire et profitable aux autres.

Merci d’avance



WinDev le chemin le plus court !

Message envoyé le 22-09-2021 par Gracelmann (Congo)  
Chers tous j'ai enfin trouvé la solution.
Il m'a suffit d'ajouter un CHAMP (SAI) sur la Fenêtre concernée puis j'ai ajouté :


Sablier(Vrai)

SAI_DATE_SUPPRESSION = DateSys()
EcranVersFichier()

SI ONG_CONSULTATION.BAO_RESOLUTION.TABLE_RESULTAT_DOUBLE.COL_CODE_ID[ligneComptage] <2 ALORS
     Erreur("Aucun doublon n'a été trouvé pour la sélection actuelle !")
SINON
................................

Puis j'ai extrait le Code d'après :

J’ai même ajouté ce Code ci-dessous, pas d’actualisation :

//On met à jour la Date de suppression
POUR TOUT SUPPR_Inscriptions SUR IDINSCRIPTION_FRANCS
     SI SUPPR_Inscriptions.IDINSCRIPTION_FRANCS = gnXIDParentApprenantASupprimer ALORS
          SUPPR_Inscriptions.DATE_SUPPRESSION = DateSys()
          
          HModifie(SUPPR_Inscriptions)
     FIN     
FIN


Je continue à réfléchir, cependant si quelqu’un a une solution ce serait vraiment salutaire et profitable aux autres.

Merci d’avance


Pour répondre à ce message vous devez être membre

Entrée membre    Enregistrer

  Post reply  



  
Retour © 2021 forum.acam.ca
  
Flag Counter